Author Topic: weiterleitung auf mobile funktioniert nicht (kein audio)  (Read 671 times)

mikeboss

  • Full Member
  • ***
  • Posts: 64
  • Karma: 0
    • View Profile
weiterleitung auf mobile funktioniert nicht (kein audio)
« on: May 03, 2017, 06:31:10 PM »
release 5.1.1

wenn man von einer internen nummer auf die extension, welche eine weiterleitung aktiv hat, anruft,
klappt die weiterleitung einwandfrei.

wenn man von einer externen nummer auf die extension (durchwahl) anruft, welche eine weiterleitung aktiv hat,
klappt die weiterleitung, aber kein audio (in beiden richtungen).

kein eintrag im log, fuer die PBX scheint alles ok

zielnummer (handy) als extension erfasst.

umleitung eingerichtet auf snom 760 funktioniert auch nicht.

option gemaess
http://forums.askozia.com/index.php/topic,1966.msg9125.html#msg9125
bringt auch nichts.

irgend eine idee was da scheif laufen koennte?

grz,
michael


DerThomas

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #1 on: May 04, 2017, 09:11:51 AM »
Hallo  :)

trag mal testweise folgendes unter "Manual Dialplan Incoming" und "Manual Dialplan Outgoing" in die Nst ein:

Answer()
Playback(silence/1)

Gruß
Thomas

andy

  • Sr. Member
  • ****
  • Posts: 163
  • Karma: 8
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #2 on: May 04, 2017, 10:07:35 AM »
Hallo Michael

Ich tippe auf ein NAT/Firewall-Problem. Gerne sind auch sog. SIP-HELPER/ALG auf der Firewall eine Ursache, welche korrekte Pakete falsch umschreiben.
Um mehr zu sagen, müsste man aber

Gruss

Andy

Franz

  • Full Member
  • ***
  • Posts: 91
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #3 on: May 05, 2017, 09:08:49 PM »
Versuch doch mal auf der Firewall den Port (UDP) Bereich 10000 - 10200 von aussen her zu öffnen und und gib als Zieladresse die Askozia Telefonanlage an. Vermutlich geht es dann.

Franz

mikeboss

  • Full Member
  • ***
  • Posts: 64
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #4 on: May 11, 2017, 10:00:03 AM »
danke fuer eure loesungsvorschlaege. man korrigiere mich, falls ich offensichtlich falsch liegen sollte. aber:

wenn man einen eingehenden anruf annimmt und zeitgleich von einem anderen apparat einen ausgehenden anruf taetigt, klappt das fehlerfrei. somit kann ich die firewall als ursache ausschliessen. oder?

wirklich merkwuerdig wird es, wenn man bedenkt, dass es die ersten tage nach inbetriebnahme der ASKOZIA funktioniert hat...

any ideas?


grz!
m.

alex2911

  • Newbie
  • *
  • Posts: 24
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #5 on: May 11, 2017, 12:07:51 PM »
Versuch das Szenario mal mit 3CX. Wenn es dann nicht Auftritt, ist es nicht die Firewall.
Leider ist es hier schwierig, Hilfe zu erhalten.
Deshalb überlege ich auch noch ob mir die Freiheit von Askozia so wichtig ist.

Franz

  • Full Member
  • ***
  • Posts: 91
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #6 on: May 12, 2017, 07:11:17 PM »
Hallo Michael

Gehe ich also richtig in der Annahme, dass Du mein Vorschlag (Port Bereich 10000 - 10200 öffnen) ausprobiert hast und es nicht geklappt hat. Oder? Eigenartig ist nur, dass ich genau dasselbe Problem schon an mehreren Askozia Installationen hatte und ich konnte das Problem immer damit lösen.

Franz

mikeboss

  • Full Member
  • ***
  • Posts: 64
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #7 on: May 13, 2017, 06:33:06 PM »
Gehe ich also richtig in der Annahme, dass Du mein Vorschlag (Port Bereich 10000 - 10200 öffnen) ausprobiert hast und es nicht geklappt hat. Oder? Eigenartig ist nur, dass ich genau dasselbe Problem schon an mehreren Askozia Installationen hatte und ich konnte das Problem immer damit lösen.

hm. also in der firewall sind SIP/SIP over SSL und 10000-20000 (gemaess VoIP provider) seit anbeginn offen (NAT inbound).
die fehlfunktion tritt nur bei der umleitung auf. sonst funktioniert alles fehlerfrei.

eingehendes gespraech entgegennehmen und gleichzeitig ein abgehendes starten/fuehren klappt einwandfei.

grz!
michael

mikeboss

  • Full Member
  • ***
  • Posts: 64
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #8 on: May 15, 2017, 03:22:17 PM »
Hallo  :)

trag mal testweise folgendes unter "Manual Dialplan Incoming" und "Manual Dialplan Outgoing" in die Nst ein:

Answer()
Playback(silence/1)

Gruß
Thomas

hallo thomas

heiliger bimbam! das hat funktioniert! dann ist es definitiv ein bug in der ASKOZIA...

danke fuer deinen hinweis  8)

grz,
m.

bishop

  • Full Member
  • ***
  • Posts: 99
  • Karma: 3
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #9 on: June 01, 2017, 12:46:55 AM »
Gibt es den Bug in der 5.3 noch?

Danke auch hier nochmal für den Top Tip von Thomas!

mikeboss

  • Full Member
  • ***
  • Posts: 64
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #10 on: June 01, 2017, 04:40:39 PM »
Gibt es den Bug in der 5.3 noch?


soviel ich weiss ist der bug bis anhin nicht behoben. in den release notes zu 5.3 wird jedenfalls nichts erwaehnt...

gerdshi

  • Newbie
  • *
  • Posts: 8
  • Karma: 0
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #11 on: June 08, 2017, 05:33:58 PM »
Bei mir hat der Tip mit der Portweiterleitung geholfen. Ich könnte mir auch vorstellen, wieso es NUR bei RUL passiert. Weil bei der SIP-Aushandlung der Sitzung, bei RUL durchaus eingehende Anfragen über den Mediaport gibt.
Bei bei "normale" ausgehende und eingende Anrufe aber dies nicht der Fall bzw. der Router die Zuordnung gerade noch aus co schaft wohin er die ankommende UDP leiten soll.

Und das ein Answer im Diaplan hilft, ist auch verständlich, denn dann laufen die Mediadaten den Weg eines "normalen" Anruf. Stichwort ohne reinvite.

Ist aber nur eine Vermutung von mir - IMHO.

goseph

  • Hero Member
  • *****
  • Posts: 840
  • Karma: 34
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #12 on: June 10, 2017, 03:54:09 PM »
Askozia 5.4 ist erschienen. Im Changelog steht u.a.:
fixed no audio on transfer to external phones (sometimes, due to bug #144518899)
« Last Edit: June 10, 2017, 03:56:26 PM by goseph »

cubewerk

  • Sr. Member
  • ****
  • Posts: 135
  • Karma: 1
  • Zertifizierter Askozia Partner
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #13 on: July 19, 2017, 07:06:30 AM »
Gerade 5.4 probiert. Problem besteht noch und

Answer()
Playback(silence/1)

ist keine Lösung. Das Problem ist derzeit bei Askozia unter der Ticket-Nummer #15157 erfasst und in Bearbeitung. Hier die Details von uns:

So kann es nachvollzogen werden:

Ext. Telefon anlegen mit Nummer 0179-.......

In CF ANSWER -> Extension -> ext. Telefon

Anruf CF-Nummer.

Es klingelt jetzt zwar beim Anruf beim ext. Telefon, der eigentliche Anrufer hört jedoch kein Klingeln (und in meinem Test auch keinen Ton nach dem Abheben).

Anruf des externen Telefons über int. Nummer geht problemlos.
« Last Edit: July 19, 2017, 07:10:00 AM by cubewerk »

MIp

  • Hero Member
  • *****
  • Posts: 219
  • Karma: 9
  • Askozia Certified Partner ***
    • View Profile
Re: weiterleitung auf mobile funktioniert nicht (kein audio)
« Reply #14 on: July 19, 2017, 08:31:15 AM »
Unser "Workaround"
Intern -> Ext-Telefon [20] -> 09561 123456
Extern -> CF [390020] -> Dial 09561 123456
Sprich, wir haben die Nummer zwei mal definiert, einmal als Externe Nummer für Intern und einmal im CF direkt.
Versions using:
3.4
4.1.x
5.x
Phones using:
Tiptel 31xx, Snom 7xx/3xx, Yealink SIP T4x