Author Topic: v4.1.5 Secure calling enabled, then disabled. No calls coming through after.  (Read 1033 times)

fysen

  • Full Member
  • ***
  • Posts: 63
  • Karma: 0
    • View Profile
I just upgraded to 4.1.5. The firewall/fail2ban is new to me, and so is Secure Calling. I enabled Secure Calling and created a cert (just to check it out). Then deleted the cert again. Secure Calling is marked disabled, but no calls succeed internally anymore.  I get errors like these:

Quote
2016-03-15 22:51:09 asterisk[2249]: WARNING[2262]: chan_sip.c:9488 in process_sdp: We are requesting SRTP for audio, but they responded without it!

Does it mean that Secure Calling isn't disabled properly? How can I fix it?
No SIP clients we use are compatible with Secure Calling.

I didn't actually test internal calling after upgrade to 4.1.5 - before I enabled the Secure Calling.
The version I had before was v3.3.4 and it worked beautifully, and the configuration haven't changed after upgrading, except for the new stuff and the license.

Regards Knut
« Last Edit: March 15, 2016, 11:24:01 PM by fysen »

fysen

  • Full Member
  • ***
  • Posts: 63
  • Karma: 0
    • View Profile
I stand corrected.  Our softphones (MicroSIP) have a setting 'auto' for encryption. Our Gigaset A580IP phones does not.
If I set softphone encryption to disable, calling works.
But this is already disabled in Askozia, so why is asterisk loading/using it anyway?

I've found this may be a problem in asterisk 11, and others have solved it with adding the following to modules.conf:
noload=res_srtp.so

Is this the best sollution?

Thanks!

Wbr Knut
« Last Edit: March 16, 2016, 07:25:05 PM by fysen »

fysen

  • Full Member
  • ***
  • Posts: 63
  • Karma: 0
    • View Profile

modules.conf: noload=res_srtp.so

... solves the problem. Still it must be a bug in asterisk.


k