Author Topic: Callforwarding with 000023*XXX*XXX does not work  (Read 5481 times)

DeepB

  • Full Member
  • ***
  • Posts: 52
  • Karma: 2
    • View Profile
Callforwarding with 000023*XXX*XXX does not work
« on: December 14, 2015, 07:41:58 AM »
Hello,

when trying to use call-forwarding calling 000023 and then typing the extension to forward to does work.
However when trying to call 000023*own_ext*forward_ext it does not work.

When calling for instance 000023*116*120 (forward 116 (own ext) to 120) nothing happens. In the log I see the phone going offline (?).

Any ideas?

thanks
Daniel

toxicfusion

  • Sr. Member
  • ****
  • Posts: 171
  • Karma: 6
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #1 on: December 15, 2015, 02:50:23 PM »
Which phones and Askozia PBX version are you using?

is ext 120 an external phone?

DeepB

  • Full Member
  • ***
  • Posts: 52
  • Karma: 2
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #2 on: December 16, 2015, 07:34:58 AM »
both are internal phones.

Askozia 4.1.3
Yealink T48G
Yealink T46G


It does however work on our dect phones.

toxicfusion

  • Sr. Member
  • ****
  • Posts: 171
  • Karma: 6
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #3 on: December 16, 2015, 09:54:05 PM »
update to latest 4.1.4 - few more bug fixes Ive noticed..

Then make sure phone is auto-provisioned.  If issue persists.

Remove MAC address from phone extension Auto-Configuration.  Reboot phone.  Once phone back online, obtain its local IP, and access webGUI

from within the webGUI assign the programmable key a BLF key to  000023*116*120

DeepB

  • Full Member
  • ***
  • Posts: 52
  • Karma: 2
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #4 on: December 17, 2015, 08:15:01 AM »
It is auto-provisioned. I already tried resetting, rebooting and putting it onto a BLF field.

This is a proble I have with _all_ my 10 Yealink phones.

The only thing I did not yet do is update to 4.1.4. There is no mention of this bug in the changelog, and as it seems that they often introduce problems with updates I'd rather wait a bit.

Daniel

DeepB

  • Full Member
  • ***
  • Posts: 52
  • Karma: 2
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #5 on: December 17, 2015, 02:23:10 PM »
I got an answer from Yealink. Calling anything with * in it is not supported in any Yealink phone.

So this means that with the phones that are supported by Askozia (Yealink) I cannot even use one of the very basic functions of any pbx? Usable call forwarding? Even my 10+ year old analog pbx was able to configure one key of my phone to enable call forwarding to specific number.

Any workaround?

Markus Ehlers

  • Askozia Staff
  • Full Member
  • *
  • Posts: 87
  • Karma: 3
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #6 on: December 17, 2015, 05:24:50 PM »
Hi everybody,

Call Forwarding with Yealink telephones work like a charm.

I tested the following scenario a couple of minutes ago.

- AskoziaPBX 4.1.4 (on a 1GHz Desktop Telephony Server)
- Yealink T42 (Firmware: 29.80.0.70, internal nr. 201)
- Snom 710 (Firmware: 8.7.5.17, internal nr. 202)

I configured the application 000023*xxx*yyy on one BLF at the Yealink phone. (see pic01)
I configured the phone via auto-provisioning

When pressing the BLF, the application gets dialed and all incoming calls to 201 are forwarded to 202.

DeepB, if you still have problems with that, please feel free to contact our support and please provide the configuration file of your system.

Thanks and have a nice day!

Markus E. ;)
« Last Edit: December 17, 2015, 05:47:26 PM by Sebastian »

DeepB

  • Full Member
  • ***
  • Posts: 52
  • Karma: 2
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #7 on: December 18, 2015, 11:26:15 AM »
That is what I have done, it still does not work.

Before I writeto support again, maybe this has something todo with it:

Whenever I call 000023*xxx*yyy this is written into the log:

Code: [Select]
2015-12-18 11:14:31 asterisk[3670]: NOTICE[3691]: chan_sip.c:27749 in sip_poke_noanswer: Peer '116' is now UNREACHABLE! Last qualify: 7
2015-12-18 11:14:36 asterisk[3670]: NOTICE[18756]: chan_sip.c:21828 in handle_response_peerpoke: Peer '116' is now Reachable. (9ms / 2000ms)

Also I predial "0" to dial out with a specific provider.

Markus Ehlers

  • Askozia Staff
  • Full Member
  • *
  • Posts: 87
  • Karma: 3
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #8 on: December 21, 2015, 10:20:53 AM »
Hello DeepB,

I rechecked again. This time with a T48 (FW 35.80.0.70).

This works without any issues as well.

Since the only difference is the Askozia version, please update your system and the problem should be solved.

Have a nice day and a great Christmas!

Markus E. ;)

DeepB

  • Full Member
  • ***
  • Posts: 52
  • Karma: 2
    • View Profile
Re: Callforwarding with 000023*XXX*XXX does not work
« Reply #9 on: December 22, 2015, 07:38:50 AM »
I wrote to support and we checked it out, the solution is that pre-4.1.4 it seems to only work with secure-calling OFF.

Thanks for the help, I'll do an update in the next days.

Daniel