Author Topic: Problema telefonate in ingresso provider SIP -> appende dopo 1 squillo  (Read 3873 times)

Mutation

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
Salve a tutti,
Sono nuovo del meraviglioso mondo Askozia anche se ho lavorato parecchi anni fa su m0n0wall per scopi didattici.

Ho di recente acquistato un'alix dove gira la versione DIET di Askozia.

Le chiamate interne funzionano alla perfezione.

Ho tolto dal mio ATA il mio operatore VOIP e settato in Askozia. Viene registrato correttamente e sul sito del Provider appare AskoziaPBX come Agent quindi perfettamente attuale.

Ora appena provo a fare una chiamata, suonano i telefoni collegati una volta, e poi la chiamata viene terminata (occupato).

Cosa può essere il problema?

Premetto che le chiamate in uscita con il provider funzionano perfettamente...

Grazie in anticipo per i preziosi consigli!

Saluti dalla Svizzera

Mutation

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
Nessuno che abbia un consiglio?
Le ho provate un po'. tutte ma con il medesimo risultato.

Mutation

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
mi rispondo da solo... alla fine erano le regole nel router che non facevano il forwarding correttamente...
Sul Pirelli ho impostato il forwarding delle porte dalla 5065..5070 sia in entrata che in uscita verso Askozia. (la 5060 la utilizza purtroppo un FB ATA e non posso modificarla)

Ora le telefonate arrivano senza problemi, ma se inserisco un secondo operatore voip non funzionano più entrambi... qualcuno mi illumina se è un problema di configurazione su Askozia oppure ancora sul router?  :P

Mutation

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
mi ri-ripondo da solo.
Allora:
- problema dei 2 operatori voip risolto
- firewall disabilitato (non era neppure abilitato sul router ed avevo cmq fatto il port fw)
- niente NAT

Sono tornato al problema di partenza:
1) Ho rimesso Askozia sulla 5060 (sulla 5065 funzionava tutto alla grande a parte il PAP2T che non mi si collegava anche dicendogli che la porta era la 5065... - questo tra l'altro è in un vecchio post)
2) L'ATA FB l'ho scollegato quindi niente + doppioni
3) I provider SIP sono registrati ed occupano le porte 5060 e 5061
4) Il PAP2T è collegato sulla linea 1 ad un interno tramite la 5060
5) In telefono Cisco anche con tutte le porte che puntano alla 5060

Risultato:
- Tutti gli interni sono registrati e si parlano senza problemi
- chiamate in uscita senza problemi
- chiamate in entrata...  :o fa il solito squillo e poi appende
---> con ascozia sulla 5065 invece funzionavano se non per il problema al punto 1)

Dove sbaglio?!?!?  ??? ??? ??? ???

Mutation

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
+ che delle domande sta diventando un monologo-manuale per qualcuno che magari in futuro avrà i miei stessi problemi...

Fatto un passo avanti:
Sul telefono Cisco 7940 sono settate le MediaPort (RTP in Askozia) dalla 16384..32766 e così ho modificato anche in Askozia

Risultato  ;D ora un provider Sip almeno risponde senza appendere dopo 1 squillo...

Ora il problema rimane per l'altro... ma quante porte hanno bisogno "sti ingordi"? C'è una teoria? Per favore spiegatemela...sto andando solo a tentativi... ;)

user469

  • Hero Member
  • *****
  • Posts: 201
  • Karma: 5
    • View Profile
Parto dal fondo per comodita :)

Ogni comunicazione ha bisogno di 3 porte rtp moltiplicate per il numero di telefonate concorrenti che si pensa di avere sul centralino .

La maggior parte dei device o provider supportano solo alcune porte sip , alcuni 5060 5061 5062 , altri 5060 5070 5080 , in caso di problemi non usare le stesse porte dappertutto .

Di solito i maggiori problemi di audio o delle telefonate che cadono sono legate ad errate configurazioni dei router , dei firewall , e del nat .

Ciao

Mutation

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
    • View Profile
Parto dal fondo per comodita :)

Ogni comunicazione ha bisogno di 3 porte rtp moltiplicate per il numero di telefonate concorrenti che si pensa di avere sul centralino .

La maggior parte dei device o provider supportano solo alcune porte sip , alcuni 5060 5061 5062 , altri 5060 5070 5080 , in caso di problemi non usare le stesse porte dappertutto .

Di solito i maggiori problemi di audio o delle telefonate che cadono sono legate ad errate configurazioni dei router , dei firewall , e del nat .

Ciao


Scusa se ti rispondo a + di 1 anno di distanza.

Ti ringrazio molto per le tue delucidazioni!

Saluti