Author Topic: Askozia's PHP Interface for other Great Projects  (Read 2822 times)

Siliconsoul

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Askozia's PHP Interface for other Great Projects
« on: February 20, 2011, 10:31:01 AM »
Hi,

I am totally amazed by Askozia's webgui and would love to use it in another project. I'm basically setting up a server that can communicate with my dear Arduinos but as for the configuration, a command-line interface would be too complicated for end-users.

It would be great if someone can help me on how to get a bare T2 + PHP based Web-GUI running.

Thanks in advanced.

Siliconsoul

Siliconsoul

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
    • View Profile
Re: Askozia's PHP Interface for other Great Projects
« Reply #1 on: March 11, 2011, 08:08:01 AM »
I went ahead at removing all the applications I do not need in my project such as Asterisk and also took an attempt at modifying the PHP files but after creating the image there is an error which won't let me complete the image creation. Does anyone have an idea to this?

I would later like to include my application which should provide a specific service to the network enabled Arduinos. The Arduinos should be configurable via this system which should send the configurations to the Arduinos via the hardcoded device serial numbers. The system providing the service should of course also be configurable via the interface.

giovanni.v

  • Hero Member
  • *****
  • Posts: 694
  • Karma: 53
    • View Profile
    • BoneOS SDK &  TeeBX VoIP communication platform
Re: Askozia's PHP Interface for other Great Projects
« Reply #2 on: March 12, 2011, 12:20:04 PM »
Besides the fact that is slightly off topic...

I went ahead at removing all the applications I do not need in my project such as Asterisk and also took an attempt at modifying the PHP files but after creating the image there is an error which won't let me complete the image creation. Does anyone have an idea to this?

What means *this*?? Which error?
Look at the build log then report the exact error, otherwise no one can help.

However, the first thing that comes to my mind is that you may not have the build script in sync with the package list.

Quote
bare T2 + PHP based Web-GUI running

First consider that the php versione in askozia is quite old.

T2 appear to be very interesting for the large number of packages able to cross-compile but, imho, the build process is almost not documented; the T2 book is a great effort but mainly speaks about the host system, says a little about building a target from scratch.
Given this I think you should consider some better documented and perhaps even easier to use linux build tools.
Here are some links that might interest:
- http://buildroot.uclibc.org/
- http://www.scratchbox.org/
- http://openembedded.org/